Home & News Screenshots About  
  Downloads Development Media  
  Documentation File Bug  
JW Games >>
Jimmy's World >>
Onyx Downloads

Installing

MAKE SURE TO UNINSTALL THE CURRENT BETA BEFORE INSTALLING!

In Linux simply run the .run file once you have finished downloading it with BitTorrent. If the permissions have changed on the file use:
sh <filename>.run

In Windows install it as you would any other program.

Distribution Specific Install Instructions

Debian/Ubuntu

It would seem that both libsdl-1.2 and libsdl-2.0 need to be installed for Onyx to run. Additionally, at least the following packages which may not be installed by default will need to be installed:

  • libsdl-image1.2
  • libsdl-ttf2.0-0
  • libsdl-net1.2
  • libsdl-mixer1.2
  • libsdl1.2debian-oss (Special note, the -oss may be -alsa, -esd or others depending on the sound driver you are using)

Downloads

Binaries

Linux

Windows

OS X

No Packages are available at this time

Source

No Packages are available at this time

Bittorrent

If you have no idea what bittorrent is you can learn about it at BitTorrent.com among other places.

If Onyx totally fails to run you can email me and we'll start hacking at it.

Jimmy's World.org, JWGames.org & Onyx pages, associated art, files and documents are copyright Aaron Cameron 1996-2017
For more legal information and page contributers see the license page.

Running with JW 5.x Compat Libraries